Welcome to PetForums

Join thousands of other pet owners and pet lovers on the UK's most popular and friendly pet community and discussion forum.

Sign Up

allponds EF150

Discussion in 'Coldwater Aquarium Advice' started by Daruma, May 18, 2019.


  1. Daruma

    Daruma PetForums Junior

    Joined:
    Apr 27, 2019
    Messages:
    33
    Likes Received:
    3
    Thanks to all replies. It's fixed now. But unable to reply directly as keep getting ERROR and No there was nothing inappropriate in message.


    Hi Ruskin was right : buy cheap buy twice. Unless someone can advise me on getting this can' to work.

    I have followed all the instructions ( such as they are) and also the trouble shooting, Allponds Support page Even tried the advice I found on Amazon. -Expletive!!
    Ok I'm a newbie and non technical but this should be simple- I thought.

    I cannot get the tank water to flow into can. I cant even get it to flow through the tube with the lid off can- as was suggested by one piece of advice.
    And it certainly does not pump anything out of the can' that is filled up with tank water.
     
    #1 Daruma, May 18, 2019
    Last edited: May 21, 2019
  2. NaomiM

    NaomiM Love my furry, feathered and finned family

    Joined:
    Sep 22, 2012
    Messages:
    2,613
    Likes Received:
    2,698
    All Pond Solutions are generally considered a decent budget brand. However I don't have one myself so hard to offer specific advice. A pic might help?

    Probably way too obvious but I assume you've fully opened both the valves (one on the intake pipe and one on the output pipe)? And then attempted to prime the filter?
     
  3. magpie

    magpie PetForums VIP

    Joined:
    Jan 3, 2009
    Messages:
    2,527
    Likes Received:
    3,518
    Is it this one? https://www.allpondsolutions.co.uk/aquarium/filters/external/ef-150-400-l-h/

    I have two All Pond Solutions external filters, but mine are the much bigger ones and the style is completely different, so I'm not sure about this one. Have you filled up both tubes completely with water? Some filters don't prime very well if there is too much air in the system.

    Is anything happening when you plug it in? Can you hear the motor running?
     
  4. Daruma

    Daruma PetForums Junior

    Joined:
    Apr 27, 2019
    Messages:
    33
    Likes Received:
    3
    Thanks , I am want to overlook the obvious However in this case there is only one tap and I opened it. I took another look at the pump and impeller,
    Now here's the Techy bit :) I jiggled it about a bit and it kicked off straight away.
     
    NaomiM likes this.
  5. niamh123

    niamh123 PetForums VIP

    Joined:
    Nov 4, 2018
    Messages:
    2,476
    Likes Received:
    1,825
    I had one of these for my tank you need to tip it upside down a couple of times whilst turned off to get it going:)
     
    Daruma likes this.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice